io.wcm.maven.global-parent: Maven Plugin Updates

Description

update to latest maven plugin version esp. for static code analysis.

checkstyle plugin 2.15 fixes some isses with java 8.

perhaps we can update to latest cobartura 2.7 for java 8 compatibility as well - in the last update round beginning of march '15 we had to skip it because of compatibility problems with felix bundle plugin baseline check and some unit test runs.

for maven bundle plugin we should skip version 2.5.4 due to a known issue, perhpaps update to a intermediate release of the latest version to get the latest bndlib 2.4.1

Activity

Show:
Stefan Seifert
May 22, 2015, 1:36 AM

updates applied, and updated all plugin in aem-global-parent as well.

for the maven-bundle-plugin we are using an intermediate release from current 2.5.5-SNAPSHOT.

there are still problems with cobertura 2.7 and bundle plugin baseline check - but not in all projects, only in the main wcm.io build with compile target 2.7. we downgraded cobertura in wcm.io parent_toplevel back to 2.6.

Stefan Seifert
May 18, 2015, 5:02 PM
Edited

rev. 0837f69 - updated plugins/dependencies:

wagon-ssh 2.9
maven-assembly-plugin 2.5.4
maven-checkstyle-plugin 2.15
maven-compiler-plugin 3.3
maven-jar-plugin 2.6
maven-javadoc-plugin 2.10.3
maven-scm-provider-gitexe 1.9.4
maven-scm-plugin 1.9.4
findbugs-maven-plugin 3.0.1
cobertura-maven-plugin 2.7

Fixed

Assignee

Stefan Seifert

Reporter

Stefan Seifert

Labels

None

Components

Fix versions

Priority

Minor