AEM-Dependencies should also be created for 6.3 SP1, and also for CFPs

Description

Currently AEM Dependencies exist for the following versions:
https://github.com/wcm-io/wcm-io-tooling/tree/develop/maven/aem-dependencies

Some issues:

  • 6.3 SP1 is missing

  • CFP versions are missing

  • By using the AEM-Dependencies, I still had to manually add a dependency to the Apache Commons library specifically (since the dependencies only point to the OSGi wrappers)

What would be the prefered approach here? Ideally, I think we should keep these dependencies up-to-date as much as possible, as otherwise the whole benefit of having this is removed; Currently I can use these dependencies in my 6.3 SP1 project, but I will get in trouble as soon as I need a newer version of any of the dependencies.

Activity

Show:
Henry Kuijpers
November 21, 2017, 5:41 PM

Hi ,

What would be your recommendations here?

I'd suggest adding at least:

  • 6.3.1.0000 (AEM 6.3, SP1, with no CFPs)

  • Maybe also 6.2.1.0000 & 6.2.2.0000?

What about adding packages that also have the dependencies that are contained in their CFPs?

What are your recommendations regarding gathering these dependencies? There must be a certain process that you are following while assembling this pom.xml. I wouldn't mind investing some time in making a 6.3 SP1 and one with a CFP's dependencies in it available.

Stefan Seifert
November 22, 2017, 10:10 AM

currently we maintain only dependency for the GA releases for each AEM version,
also they are some API updates between service packs - and sometimes even for CFPs - we found it sufficient to deploy our applications only against the GA release APIs.

if there is a need i would be happy to include dependency definitions for service packs as well. not sure if it really makes sense for the CFPs, they have only a short lifetime until the next SP is out and the difference API-wise to the last SP is only very small.

we maintain these API definitions currently manually, and there may be some bundles missing we overlooked or for some other reason did not include. in case of osgi wrapper libraries it makes sense to include the original library instead.

if you come up with a PR i will have a look at it.

Stefan Seifert
December 1, 2017, 11:17 AM

i've added a dependency pom for AEM 6.3.1 (important if you use the latest Core WCM Components version 1.1.0 or higher which depends on SP1 of AEM 6.3):

it's not yet released - you can give the snapshot a try.

Stefan Seifert
December 1, 2017, 11:18 AM

By using the AEM-Dependencies, I still had to manually add a dependency to the Apache Commons library specifically (since the dependencies only point to the OSGi wrappers)

i had a look ad this as well - but did not find which of the apache commons library you mean? most of the libraries that are still relevant are references without wrapper.

Fixed

Assignee

Unassigned

Reporter

Henry Kuijpers

Labels

None

Components

Priority

Major
Configure