Error in creating a new AEM Project with maven

Description

Hi,

I tried to build a new Project with maven 3.6.3 und Archetype 3.2.6. I used the following command

After generating some stuff, the maven script Ends with

Can you reproduce this? Is there a problem with my Parameters?

Activity

Show:
Stefan Seifert
October 29, 2020, 6:37 PM

you mean it does also not work if you try to download groovy-xml:2.4.16 via dependency:get on your machine? then it looks really that you may have problem with your maven artifact repository manager - try to use maven central directly as an alternative.

if i use the latest version of maven dependency plugin i can download the artifact directly:

and i've also tried the archetype generation with openjdk 11.0.4 - it works fine as well on my machine.

Jürgen Bäckmann
October 29, 2020, 6:16 AM

Now another error raises. Is there another version conflict?

Perhaps with the used jdk 11.0.5? But if it worked with Masoud’s jdk 11.0.9 it not very likely.

Even if I download it manually

 

Jürgen Bäckmann
October 29, 2020, 5:51 AM
Edited

Meanwhile I can use:

Now this error is gone. TThanks

Jürgen Bäckmann
October 29, 2020, 5:32 AM

Thanks a lot for this Information. If I delete the archetyp plugin version, 3.0.1 will be reinstalled again. So I think the might be a problem with our nexus-Installation. I will contact our Admin in this case….

Stefan Seifert
October 28, 2020, 12:15 PM

you are using a very old version of the archetype plugin (3.0.1) - current version is 3.2.0. normally maven should use/update to the latest one if you do not specify it's version explicitly - this does not seem to work on your machine?

you can try to remove the path org/apache/maven/plugins/maven-archetype-plugin from your local maven repo and thus force a download of the latest version and try again.

Assignee

Unassigned

Reporter

Jürgen Bäckmann

Labels

None

Components

Priority

Major