Include javax.servlet jstl in aem-dependencies

Description

Can the following dependency be included?
```
<!-- Not included in uber-jar & aem-dependencies -->
<dependency>
<groupId>javax.servlet</groupId>
<artifactId>jstl</artifactId>
<version>1.2</version>
<scope>provided</scope>
</dependency>
```

Activity

Show:
Stefan Seifert
March 24, 2020, 6:51 PM
Edited

https://github.com/wcm-io/wcm-io-tooling/commit/dcf3b5ebc724dbfd880a8467122bc6d19eca95d8

i've added the dependency (which contains javax.servlet.jsp.jstl.*)

to AEM dependencies versions

  • 6.4.5

  • 6.4.6

  • 6.4.7

  • 6.4.8

  • 6.5.1

  • 6.5.2

  • 6.5.3

  • 6.5.4

although i only plan to release the most recent 6.4.8 and 6.5.4.

the other org.apache.taglibs.standard.* packages are already included in the AEM uber-jar.

please cross-check the snapshots if this alternative dependency works as expected for you.

Henry Kuijpers
March 24, 2020, 3:48 PM

We're using AEM 6.4 on some projects, and AEM 6.5 on newer projects. So I think indeed it's a good idea to add it only for AEM 6.4 & 6.5. 6.2 (and 6.3?) or not supported anymore anyways.

It would be nice if there could be an updated AEM 6.4.8 with that included as well.

Stefan Seifert
March 24, 2020, 3:46 PM

makes sense - but which AEM version and service pack are you using?
for many AEM version up to AEM 6.5.0 day-commons-jstl 1.1.4 was included, which embedded those deps:

(the latter was not part of the wcm.io AEM Deps POMs)

but form AEM 6.5.1 onwards an new version day-commons-jstl 1.2.2 included, which embeds different dependencies:

i would favor adding the new deps only to wcm.io AEM dependencies files for AEM 6.5.1 and upwards, probably only for the latest 6.5.4.

Fixed

Assignee

Stefan Seifert

Reporter

Henry Kuijpers

Labels

None

Components

Priority

Minor